Hello, welcome to the Deep Silver FISHLABS forums!
Please carefully attend our rules and in all time-sensitive cases please contact our support. We hope you enjoy sharing your thoughts with other players.
Plankton

Plankton
Posts: 1
Please read all of it.

Hello I have been playing Galaxy on Fire Series ever since I can remember. I love the game and am a true fan at heart. The Galaxy on Fire Series is no doubt the best games in it's league. I play GOF2 almost everyday waiting for GOF3 to come out. I love the game and it is the best game on the app store so far. But recently when playing GOF2 I've noticed a bug. I've beaten the game and all the DLCs, and so I've been trying to get all the medals so I can unlock the fire works and the Specter. Which I did finish getting all the medals this past week. After doing so I decided to have some fun and do some side/freelance missions. I accepted mission a where I had to reclaim stolen goods from pirates without destroying the ship with the stolen goods by using EMP weapon. The location of the mission and where I recieved the mission were two different systems. For example I received the mission in the Suteo system but the system where I have to retrieve the stolen goods would be in the Vulpes system. I don't remember which systems it was but I will use Suteo and Vulpes for example. I go to the Vulpes system and reclaim the goods, which was in the form of a secure container, without destroying the ships. I was told by the client to return to the Suteo system to receive my reward. While carrying the stolen goods (secure container) I dock at one of the stations in the Vulpes system. I go to the space lounge and I see a different mission that interest me which was like a junk removal mission in the Vulpes system where I already am. So I decide instead of going all the way to the Suteo system I decide to do the junk removal mission instead. So I abandon the mission I've been doing, which is the stolen goods mission, and go do the junk removal mission. After finishing I dock at a station and I realize I still have a secure container from the mission before the junk removal mission. So now I'm stuck with a secure container in my cargo hold. I can't get rid of it because it's a secure container. I've tried everything, I can't sell it, I've tried buying a new ship, it just wont go away. I don't know what to do. I know I'm asking for a lot but is there a way you make a update for it which fixes the bug. If you have any questions or need to know more details please respond and I will respond as fast as I can. I apologize for this being so long but I would like to thank you for reading all of it. Thank you.

Sincerely Jacob